
１つの MPASM ファイルによるプロジェクトの作成
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ははははじじじじめにめにめにめに
MPLAB v3.40 のプロジェクト・マネージャーは、機能拡張により、複数のファイルをサポートで
きるようになりました。MPLAB v3.31 やそれ以前のバージョンで作成したプロジェクトは、オー
プン時に、自動的に MPLAB v3.40 フォーマットのプロジェクトに変換されます。変換後のプロジ
ェクトは、MPLAB の前バージョンでは再びオープンすることができません。

ハハハハイイイイラララライイイイトトトト
このチュートリアルでは、MPLAB プロジェクトの以下の機能を学習します。

MPLAMPLAMPLAMPLABBBB ププププロロロロジジジジェェェェククククトトトトのののの概概概概要要要要
１１１１つつつつのののの    MPAMPAMPAMPASSSSMMMM ソソソソーーーーススススフフフファァァァイイイイルルルルをををを使使使使用用用用ししししたたたたププププロロロロジジジジェェェェククククトトトトのののの作作作作成成成成
ププププロロロロジジジジェェェェククククトトトト作作作作成成成成ななななししししのののの単単単単独独独独 MPASMPASMPASMPASMMMM ソソソソーーーーススススフフフファァァァイイイイルルルルののののココココンンンンパパパパイイイイルルルル
MPLIMPLIMPLIMPLINNNNKKKK をををを使使使使用用用用ししししたたたた複複複複数数数数のののの    MPMPMPMPASASASASMMMM ソソソソーーーーススススフフフファァァァイイイイルルルルののののププププロロロロジジジジェェェェククククトトトトのののの作作作作成成成成
MPLAMPLAMPLAMPLABBBB-C1-C1-C1-C17777 をををを使使使使用用用用ししししたたたたププププロロロロジジジジェェェェククククトトトトのののの作作作作成成成成
Hi-THi-THi-THi-Teeeech ch ch ch PPPPIC IC IC IC CCCC をををを使使使使用用用用ししししたたたたププププロロロロジジジジェェェェククククトトトトのののの作作作作成成成成

このタスクを実行するために、MPLAB の以下の機能を使用します。
言言言言語語語語ツツツツーーーールルルルののののイイイインンンンスススストトトトーーーールルルル
新新新新規規規規ププププロロロロジジジジェェェェククククトトトト
ププププロロロロジジジジェェェェククククトトトトへへへへののののノノノノーーーードドドドのののの追追追追加加加加
ププププロロロロジジジジェェェェククククトトトトノノノノーーーードドドドププププロロロロパパパパテテテティィィィーーーーのののの設設設設定定定定
ププププロロロロジジジジェェェェククククトトトトのののの作作作作成成成成・・・・構構構構築築築築
ププププロロロロジジジジェェェェククククトトトトウウウウィィィィンンンンドドドドウウウウ

用用用用語語語語集集集集
プロジェクト 　　　 MPLAB のプロジェクトは、１つのアプリケーションを作成するた

めのファイル群です。構築ツールとのリンクも含みます。
構築ツール 　 通常はコンパイラ、アセンブラ、または、リンカ。
ノード 　　　 いくつかの種類のファイル。プロジェクトのコンポーネント。
プロジェクトノード　　 プロジェクトの最上位レベル。その他すべてのファイルは、こ

のノードを構築するために使用します。
ソースノード 　　 アプリケーションを構築するためのコンポーネントファイルの 1

つ。これは、アセンブラのソースファイル、C言語のソースファ
イル、あらかじめコンパイル済のオブジェクトファイル、ライ
ブラリ、またはリンカのスクリプトのどれかです。。

プロジェクトの作成 ソースコードまたはプロジェクトオプションに変更があった場
合のみ、すべてのソースノードをコンパイル、アセンブル、リ
ンクしてアプリケーションを構築すること。

プロジェクトの構築 無条件で、すべてのソースノードをコンパイル、アセンブル、
およびリンクをすること。
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MPLAMPLAMPLAMPLABBBB ププププロロロロジジジジェェェェククククトトトトのののの概要概要概要概要
MPLAB のプロジェクトはアプリケーションの構築に必要なファイル群です。各種構築ツールとフ
ァイル群の関連付けも行います。プロジェクトは、プロジェクトノードと、１つまたは複数のソ
ースノードで構成されます。ソースノードの代表的なものは、MPASM ソースファイル、 MPLAB-
C17 ソースファイル、コンパイル済のライブラリと、オブジェクトファイル、リンカスクリプト
です。通常、プロジェクトは、メインソースファイルと同じディレクトリに格納します。

プロジェクト関連図

プロジェクトの各ノードは、それぞれ言語ツールで関連付けされます。プロジェクト作成時に、
必要ない場合を除いて、言語ツールを割り当てなければいけません。例えば、MPASM を１つのソ
ースファイルで使用している場合（次に出てくる最初のチュートリアルを参照）、プロジェクト
ノードがすでに MPASM にセットアップされているので、ソースファイルノードに言語ツールを割
り当てる必要がありません。同様に、MPLAB-C17 用または MPASM 用のコンパイル済ライブラリ、
オブジェクトファイル、リンカのスクリプトは、常に MPLINK により作成されるためツールを割
り当てる必要がありません。

それぞれの言語ツールには複数のオプションがあります。オプションは DOS 上で起動した場合は
コマンドラインスイッチで設定します。オプションは各編集可能なノードのノードプロパティと
して表示されます。オプションのスイッチは.MAP ファイル生成をする/しない、適切な.HEX フォ
ーマットの選択、警告メッセージの表示/非表示などを制御します。オプションは、１つのプロ
ジェクトの各種ソースノードに対して別々に設定可能ですが、ほとんどの場合は同じ設定となり
ます。ノードプロパティダイアログは各種ツールのコマンドラインスイッチに対応しており、初
めて開く時、ダイアログはデフォルト値を表示します。これらのコマンドラインスイッチについ
ては MPASM と MPLAB-C17 のユーザーズガイドを参照してください。

MPLAB のプロジェクトマネージャの構築は MAKE で行います。このツールは、そのプロジェクト
の全アプリケーションを作成するソースファイルの更新日時を確認して、プロジェクトが再リン
クされる時に、どのコンポーネントが変更され、再コンパイルまたは再アセンブルが必要である
かを判定します。
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１１１１つつつつのののの MPAMPAMPAMPASSSSMMMM ソソソソーーーーススススフフフファァァァイイイイルルルルにににによよよよるるるるププププロロロロジジジジェェェェククククトトトトのののの作作作作成成成成
1つのソースファイルのみのプロジェクト、または以前の方法(MPLAB バージョン 3.31 以前)を使
用するプロジェクトを作成するには、次のステップに従います。ただし、ソースファイルは、他
のファイルを＃include できます。

１つの MPASM ソースファイル･チュートリアルのプロジェクト関連図

開開開開発発発発モモモモーーーードドドドのののの設設設設定定定定
アプリケーションに対して適切な開発モードを選択します。ここでは、Options>Development
Mode の設定を MPLAB-SIM シミュレータにして、16F84 PICmicro を選択します。

図 1

プロジェク
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新新新新規規規規ののののププププロロロロジジジジェェェェククククトトトト
 Project>New Project を選択して、新規プロジェクトのディレクトリを選択し、名前を入力し
ます。ここでは MPLAB インストールディレクトリを使用し、名前を SAMPLE.PJT とします。

　　図 2

ププププロロロロジジジジェェェェククククトトトトダダダダイイイイアアアアロロロロググググ
OK をクリックすると Edit Project ダイアログが開きます。

図 3
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ノノノノーーーードドドドププププロロロロパパパパテテテティィィィのののの設設設設定定定定
｢Project Files｣ウィンドウで、ファイル名 SAMPLE.HEX をクリックし、「Node Properties」ボ
タンを選択します。

図 4

注注注注意意意意:::: ｢Node Properties｣ダイアログはツールのコマンドラインのスイッチ（この場合 MPASM）
を表示します。最初にこのダイアログを開けると、チェックボックスにはこのツールのデフォル
ト値が表示されます。このチュートリアルではチェックボックスの変更を行う必要はありません。
コマンドラインスイッチについての詳細は MPLINK、MPASM および MPLIB ユーザーズガイドを参照
してください。

OK を選択すると、Edit Project ダイアログボックスに戻ります。

ノノノノーーーードドドドのののの追追追追加加加加
Edit Project ダイアログから「Add Node」を選択します。ここでは SAMPLE.ASM を使用してくだ
さい。これは、「Add Node」を選択すると現れるブラウズウィンドウです。

図 5

MPASM は常にソース.ASM ファイルと同じ名前の.HEX ファイルを作成します。プロジェクトが構
築されると、プロジェクトマネージャーは SAMPLE.HEX ファイルを作成します。
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Edit Project ダイアログは次のように表示されます。

図 6

注注注注意意意意：：：：この簡単な例では、「Path」ボックスの中に何も入力されていません。アプリケーション
が複雑になるに従って、該当するボックスに Include File のディレクトリを入力する必要とな
る場合があります。

Edit Project ダイアログの「OK」ボタンをクリックします。

ププププロロロロジジジジェェェェククククトトトトのののの作作作作成成成成
メニューから Project>Make Project を選択し、MPASM を使用してアプリケーションをコンパイ
ルします。Build Result ウインドウが作成され、アセンブラに送信されたコマンドラインを表
示します。次のような表示になります。

図 7
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トトトトララララブブブブルルルルシシシシュュュューーーーテテテティィィィンンンンググググ
問題がある場合は、次の項目をチェックします。

Project>Install Language Tool... を選択し、MPASM が MPLAB インストールディレクトリ内の
MPASM.EXE に指定されていることを確認します。代わりに MPASM を MPASMWIN.EXE に指定するこ
ともできますが、「Windowed」オプションを選択する必要があります。

図 8

DOS から環境スペースが足りないというメッセージを受信した場合、MPLAB インストールディレ
クトリの MPASM.EXE ファイルを選択します。マウスの右ボタンをクリックして、プロパティダイ
アログを表示させます。

図 9

環境変数の初期サイズの容量を増やします。通常、2048 の設定で十分ですが、AUTOEXE.BAT ファ
イルの中に、変数を設定したり、パス文を追加するアプリケーションがたくさんある場合、環境
変数の初期サイズを大きくする必要がある場合があります。

ププププロロロロジジジジェェェェククククトトトトウウウウィィィィンンンンドドドドウウウウ
 Window>Project ウインドウを開いて、ターゲット名がノードのソース名と一致するよう正しく
設定されているのを確認します。ファイルの拡張子は、.ASM と.HEX のように異なりますが、こ
のチュートリアルでは両方とも SAMPLE と名付けられています。
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プロジェクトウィンドウは次のように表示されます。

図 10

MPASMMPASMMPASMMPASM１１１１つつつつののののフフフファァァァイイイイルルルルののののププププロロロロジジジジェェェェククククトトトトののののセセセセッッッットトトトアアアアッッッッププププののののままままととととめめめめ
この章で説明した新規プロジェクトのセットアップ手順について簡単にまとめます。
· Project>NewProject で新規プロジェクトを作成します。
· プロジェクトのノードプロパティの設定を MPASM にして、必要なオプションを選択します。
· ソースファイルノードを追加します。



プロジェクトを作成しない単独の MPASM ソースファイルのコンパイル
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ププププロロロロジジジジェェェェククククトトトト作作作作成成成成ををををししししなななないいいい単単単単独独独独のののの MPASMPASMPASMPASMMMM ソソソソーーーーススススフフフファァァァイイイイルルルルののののココココンンンンパパパパイイイイルルルル
プロジェクトを開かずに単独のファイルをコンパイルすることができます。最初のプロジェクト
のセットアップは必要ありませんが、ファイルをコンパイルする時に毎回オプションを指定する
必要があります。この例では、前の例と同じアセンブル言語ファイルを使用します。

まず、開いているプロジェクトをすべて閉じます。 Project>Close Project を選択します。

開開開開発発発発モモモモーーーードドドドのののの設設設設定定定定
開発モードを選択します。ここでは、 Options>Development Mode の設定を MPLAB-SIM シミュレ
ーターにして、PIC16F84 PICmicro を選択します。

図 11

ソソソソーーーーススススフフフファァァァイイイイルルルルののののオオオオーーーーププププンンンン
アセンブルするソースファイルを開きます。ここでは MPLAB インストールディレクトリの 中に
ある SAMPLE.ASM を使用します。

図 12
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ソソソソーーーーススススフフフファァァァイイイイルルルルののののココココンンンンパパパパイイイイルルルル
メニューから Project>Build Node を選択し、MPASM を使用して SAMPLE.ASM をコンパイルしま
す。次のような「Invoke Build Tool」ダイアログが現れます。

図 13

MPASM が選択されているのを確認し、ツールのオプションの設定を上記と一致させます。
「 Invoke Build Tool｣ダイアログの「OK」をクリックしてビルドを開始します。「 Build
Results」ウィンドウが現われて、アセンブラーに送られたコマンドラインとビルド結果を表示
します。次のような表示になります。

図 14
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トトトトララララブブブブルルルルシシシシュュュューーーーテテテティィィィンンンンググググ
問題がある場合は、次の項目をチェックします。

 Project>Install Language Tool... を選択し、MPASM が MPLAB インストールディレクトリ内の
MPASM.EXE に指定されていることを確認します。代わりに MPASM を MPASMWIN.EXE に指定するこ
ともできますが、「Windowed」オプションを選択する必要があります。

図 15

DOS から環境スペースが足りないというメッセージが表示された場合、Windows のエクスプロー
ラを使用して、MPLAB インストールディレクトリ内の MPASM.EXE ファイルを選択します。次に、
マウスの右ボタンをクリックして、プロパティダイアログを表示させます。

図 16

環境変数の初期サイズの容量を増やします。通常、2048 の設定で十分ですが、AUTOEXEC.BAT フ
ァイルに変数を設定したり、パスステートメントを追加するアプリケーションが多くある場合、
環境変数の初期サイズを大きくする必要があるかもしれません。

単単単単独独独独のののの MPMPMPMPAAAASM SM SM SM フフフファァァァイイイイルルルルののののココココンンンンパパパパイイイイルルルル設設設設定定定定ののののままままととととめめめめ
この章で説明した新規プロジェクトのセットアップ手順について簡単にまとめます。
· オープン中のプロジェクトがあれば、 Project>Close Project を使用してこれを閉じます。
· コンパイルしたいソースファイルを開きます。
·  Project>Build Node を選択します。
· Invoke Build Tool ダイアログからの言語、ビルドツール、ビルドオプションを選択します。
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· 
複複複複数数数数のののの MPAMPAMPAMPASSSSMMMM ソソソソーーーーススススフフフファァァァイイイイルルルルとととと MPLINMPLINMPLINMPLINKKKK にににによよよよるるるるププププロロロロジジジジェェェェククククトトトトのののの作作作作成成成成  　　　　
MPLINK を使用して複数のオブジェクトファイルをリンクするには、次の手順で行います。前章
から続ける場合、Project>Close Project を選択します。

  
複数の MPASM ソースファイルのプロジェクト関連図

開開開開発発発発モモモモーーーードドドドのののの設設設設定定定定
 Options>Development Mode の設定を MPLAB-SIM シュミレータにして、この例では PIC16F84 を
選択します。

図 17
新新新新規規規規ププププロロロロジジジジェェェェククククトトトト
 Project>New Project を選択して、Browse により新規プロジェクトのディレクトリを選択し、
名前を入力します。ここでは ¥MPLAB¥EXAMPLE を使用して EXAMPLE.PJT.と名付けてください。

図 18
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ププププロロロロジジジジェェェェククククトトトトノノノノーーーードドドドププププロロロロパパパパテテテティィィィのののの設設設設定定定定

Edit Project ダイアログの「Project Files」ダイアログからプロジェクトノードのファイルネ
ームを選択し、｢Node Property｣を押してこのダイアログを表示させます。言語ツールの設定を
「MPLINK」にします。

図 19

注注注注意意意意: : : : Node    Property のダイアログはツールのコマンドラインスイッチ(この場合、MPLINK)を表
示します。最初にこのダイアログを開くと、チェックボックスにはツールのデフォルト値が表示
されます。このチュートリアルでは変更する必要はありません。これらのコマンドラインスイッ
チについての詳細は MPLINK、MPLIB および MPASM のユーザーズガイドを参照してください。

OK をクリックすると、Edit Project ダイアログボックスへ戻ります。

１１１１つつつつめめめめののののソソソソーーーーススススフフフファァァァイイイイルルルルノノノノーーーードドドドのののの追追追追加加加加
Edit Project ダイアログから「Add Node」を選択します。ここでは ¥MPLAB¥EXAMPLE ディレク
トリの EXAMPLE.ASM を使用します。

図 20



複数のMPASM ソースファイルと MPLINK によるプロジェクトの作成

MPLAB プロジェクトチュートリアル  14 改訂 B

注注注注意意意意:::: Windows の標準的な方法を使用して、ダイアログから複数のファイルを一度に選択するこ
ともできます。この場合、1つのファイルを選択して、次にコントロールキー（2つのファイル
のみ選択する）またはシフトキー（２つのファイルと間にあるすべてのファイルを選択する）を
押しながら、もう 1つのファイルを選択します。

Edit Project ダイアログ内のプロジェクトファイルリストから example.asm を選択し、「Node
Properties」をクリックします。

言語ツールの設定が MPASM になっているか確認します。

図 21

注注注注意意意意: : : : Node Property ダイアログは、指定されたツールに対するコマンドラインスイッチ（この
場合 MPASM）を表します。コマンドラインスイッチについての詳細は、MPLINK、MPLIB および
MPASM ユーザーズガイドを参照してください。

OK を選択して、Edit Project ダイアログボックスへ戻ります。



複数のMPASM ソースファイルと MPLINK によるプロジェクトの作成
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ソソソソーーーーススススフフフファァァァイイイイルルルルのののの追追追追加加加加
前の 2ステップと同様に、残りのソースファイルをプロジェクトに追加します。ここでは
¥MPLAB¥EXAMPLE ディレクトリから EXAMPLE2.ASM を選択します。「Copy Node」オプションを使
用して、１つめのソースファイルと同じ Node Option の設定で継続してファイルを入力すること
もできます。 Node Option が各ファイルに正しく設定されていることを確認してください。

注注注注意意意意：：：：「Copy Node」を使用するには、Project Files ボックス内にリストされたソースノード
ファイルを１つ選択してください。次に「Copy Node」機能を選択します。「Add Node」ダイア
ログボックス内のソースファイルを 1つまたは複数選択します。ファイルを選択したら、OK ボ
タンを選びます。この手順では選択したファイルは、「Copy Node」を選択した時に選択されて
いた参照ノードと同じノードプロパティをセットアップすることになります。これは同じノード
プロパティを持つ複数のソースファイルを追加する時に便利です。

リリリリンンンンカカカカススススククククリリリリププププトトトトのののの選選選選択択択択
「Add Node」ボタンと前出の方法を使用して、リンカスクリプトを選択します。リンカスクリプ
トは MPLINK が使用するファイルで、各 PICmicro のメモリアーキテクチャーを定義します。標準
のリンカスクリプトは MPLINK と共に MPLAB インストールディレクトリ内にあります。ここでは
¥MPLAB¥EXAMPLE ディレクトリから 16F84.LKR を選択します。ノードオプションはリンカスクリ
プトには設定できません。

図 22

Edit Project ダイアログの OK をクリックします。

注注注注意意意意::::この簡単な例では、3つの「Path」ボックスには何も入力されていません。アプリケーシ
ョンが複雑になるに従って、適切なボックスに Include ファイル、Library ファイルおよび
Linker Script ファイルのディレクトリを入力する必要がある場合があります。(Include ファイ
ル、Library ファイル、Linker Script ファイルがプロジェクトと同じディレクトリにない場合)



複数のMPASM ソースファイルと MPLINK によるプロジェクトの作成
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ププププロロロロジジジジェェェェククククトトトトのののの作作作作成成成成
メニューから Project>Make Project を選択し、MPASM と MPLINK を使用してアプリケーション
をコンパイルします。「 Build Results」ウィンドウが開いて、各ツールへ送信されたコマンド
ラインを表示します。次のように表示されます。

図 23

トトトトララララブブブブルルルルシシシシュュュューーーーテテテティィィィンンンンググググ
うまく動作しない場合は、次の項目をチェックします。

MPLAB が「Time-out」というメッセージを表示した場合、OK を選択して続けます。
PC の処理スピードやプロジェクトのサイズに応じて、MPLAB がタイムアウトのメッセージを発す
るまでの時間を調整したい場合もあります。この時間は、Options>Environment Setup...を選択
し、ダイアログボックス内のタイムアウト設定を調整することで設定します。

図 24



複数のMPASM ソースファイルと MPLINK によるプロジェクトの作成
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 Project>Install Language Tool... を選択し、MPASM と MPLINK が MPLAB インストールディレ
クトリで MPASM.EXE および MPLINK.EXE を示しているかチェックします。

図 25

図 26
DOS から環境スペースが不足しているというメッセージを受信した場合、Windows のエクスプロ
ーラを使用して MPLAB インストールディレクトリの MPASM.EXE ファイルを選択します。次にマウ
スの右ボタンをクリックして、プロパティダイアログを開きます。

図 27

環境変数の初期サイズの容量を増やします。通常、2048 の設定で十分ですが、AUTOEXEC.BAT フ
ァイルに変数を設定したり、パス文を追加するアプリケーションが多くある場合、環境変数の初
期サイズを大きくしなければならない場合があります。



複数のMPASM ソースファイルと MPLINK によるプロジェクトの作成
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ププププロロロロジジジジェェェェククククトトトトウウウウイイイインンンンドドドドウウウウ
 Window>Project ウインドウを開きます。次のように表示されます。

図 28

MPLIMPLIMPLIMPLINNNNKKKK にににによよよよるるるる MMMMPASPASPASPASMMMM 複複複複数数数数フフフファァァァイイイイルルルルププププロロロロジジジジェェェェククククトトトトののののままままととととめめめめ
この章で説明した新規プロジェクトのセットアップ手順について簡単にまとめます。
· Project>NewProject により新規のプロジェクトを作成します。
· プロジェクト Node プロパティの設定を MPLINK にします。
· ソースファイルノードを追加して、必要に応じて、ノードプロパティを設定します。
· Linker Script ファイルノードを追加します。
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MPLABMPLABMPLABMPLAB----CCCC11117777 にににによよよよるるるるププププロロロロジジジジェェェェククククトトトトのののの作成作成作成作成
このチュートリアルでは MPLAB のプロジェクト上で MPLAB-C17 を使用してアプリケーションを構
築する方法を示します。前章から続けている場合は、Project>Close Project を選択します。

MPLAB-C17 チュートリアルのプロジェクト関連図

開開開開発発発発モモモモーーーードドドドのののの設設設設定定定定
Options>Development Mode を MPLAB-SIM シミュレータにセットして、デバイスを選択します。
以下の例では 17C756 を選択しています。

図 29
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MPLAMPLAMPLAMPLABBBB----CCCC17 17 17 17 言言言言語語語語ツツツツーーーールルルルののののイイイインンンンスススストトトトーーーールルルル
MPLAB-C17 が MPLAB に正しくインストールされていることを確認します。Project>Install
Language Tool ダイアログが次のように表示されます。（Executable のパスは異なる場合があ
ります。）

図 30

ウィンドウに Executable の表示が出ない場合は、Browse ボタンを使用して MCC17.EXE を探して
選択します。

新新新新規規規規ののののププププロロロロジジジジェェェェククククトトトト
Project>New Project を選択して、新規プロジェクトのディレクトリを選択し、名前を入力しま
す。 ¥MCC¥EXAMPLES¥AD ディレクトリ内で、AD.PJT と名付けます。

図 31
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プロジェクト名の設定後、OK をクリックすると、Edit Project ダイアログが表示されます。

図 32

ププププロロロロジジジジェェェェククククトトトトノノノノーーーードドドドにににに対対対対すすすするるるるププププロロロロジジジジェェェェククククトトトトオオオオププププシシシショョョョンンンンのののの設設設設定定定定
Edit Project ダイアログの「Project Files」からプロジェクトファイルの名前を選択して、
「Node Properties」をクリックします。言語ツールの設定を「MPLINK」にします。

図 33
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 注注注注意意意意: : : : Node Properties ダイアログは、指定したツールのコマンドラインスイッチ（この場合
MPLINK）を示します。このダイアログを開くのが 1回目の時は、チェックボックスにはそのツー
ルのデフォルト値が表示されます。このチュートリアルではチェックボックスを変更する必要は
ありません。このコマンドラインスイッチについての詳細は、MPLINK による MPASM および MPLIB
ユーザーガイドを参照してください。

１１１１つつつつめめめめののののソソソソーーーーススススフフフファァァァイイイイルルルルのののの追追追追加加加加
このチュートリアルでどのようにノードをセットアップしたらよいかについては、AD.BAT を参
考にしましょう。これは、  DOS コマンドラインでこのチュートリアルをコンパイルするための
バッチファイルで、¥MCC¥EXAMPLES¥AD ディレクトリ内にあります。このバッチファイルの内容
を参照してすべての必要なノードを追加します。以下はバッチファイルのリストです。

図 34

必要なノードは、AD.C （必ずコンパイルするメインソースファイル）、リンカスクリプト
P17C756L.LKR、および次のオブジェクトファイルです。

   C0S17.O - スタートアップコード
 IDATA17.O - データ初期化用のコード
 INT756L.O -  割り込み処理ルーチン
 P17C756.O - PIC17C756 レジスタの定義

Project>Edit Project メニューを選択すると、プロジェクトのセットアップに戻ることができ
ます。



MPLAB-C17 によるプロジェクトの作成
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Edit Project ダイアログから「Add Node」を選択します。  ¥MCC¥EXAMPLES¥AD ディレクトリか
らソースファイル AD.C を追加します。

図 35
Edit Project ダイアログ内のファイル名を選択して「Node Properties」をクリックします。言
語ツールの設定が MPLAB-C17 になっているのを確認します。

図 36

「Object ファイル名」は自動的に「AD.O」と設定されます。このダイアログでは他に何も変更
する必要がありません。

注注注注意意意意: : : :     Node Properties ダイアログは、指定したツール（この場合は MPLAB-C17）のコマンドラ
インスイッチを示します。チェックボックスはそのツールのデフォルト値を表示します。このチ
ュートリアルでは、デフォルト値のままでどの設定も変更する必要はありません。コマンドライ
ンスイッチについての詳細は、MPLAB-C17 ユーザーズガイドを参照してください。



MPLAB-C17 によるプロジェクトの作成
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ココココンンンンパパパパイイイイルルルル済済済済みみみみオオオオブブブブジジジジェェェェククククトトトトフフフファァァァイイイイルルルルのののの追追追追加加加加
Edit Project ダイアログから「Add Node」ボタンを使用して、¥MCC¥LIB 内の MPLAB-C17 ライブ
ラリからコンパイル済みのオブジェクトファイルを追加します。必要な全オブジェクトファイル、
C0S17.O 、IDATA17.O 、INT756L.O および P17C756.O を追加します。複数のファイルを一度に選
択するには、キーボードの「Ctrl」キーを押しながら、マウスでファイルを選択します。コンパ
イル済みのオブジェクトファイルにはオプションを設定できません。

図 37

xxx.lib （ライブラリ）ファイルを追加するには、上記と同じ手順で行えます。

リリリリンンンンカカカカススススククククリリリリププププトトトトのののの選選選選択択択択
リンカスクリプトを選択して、ノードとして追加します。¥MCC¥EXAMPLES¥AD ディレクトリのリ
ンカスクリプト、P17C756L.LKR を使用します。リンカスクリプトにはオプションの設定ができ
ません。

図 38
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MPLAB プロジェクトチュートリアル Page 25 改訂B

Edit Project ウィンドウは次のように表示されます。

図 39

Edit Project ダイアログ上で、「OK」をクリックします。

ププププロロロロジジジジェェェェククククトトトトのののの作作作作成成成成
 メニューから Project>Make Project を選択して、MPLAB-C17 と MPLINK を使用したアプリケー
ションをコンパイルします。Build Result ウィンドウが作成されて、各ツールを実行するコマ
ンドラインを表示します。次のような表示になります。

図 40



MPLAB-C17 によるプロジェクトの作成
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トトトトララララブブブブルルルルシシシシュュュューーーーテテテティィィィンンンンググググ
問題がある場合は、次の項目をチェックします。

Project>Install Language Tool... を選択して、MPLAB-C17 と MPLINK の表示が、 MCC17.EXE と
MPLINK.EXE になっているか確認します。

図 41

ププププロロロロジジジジェェェェククククトトトトウウウウィィィィンンンンドドドドウウウウ
Window>Project ウィンドウを開くと、次のように表示されます。

図 42

MPLAMPLAMPLAMPLABBBB-C1-C1-C1-C17777 ププププロロロロジジジジェェェェククククトトトトののののセセセセッッッットトトトアアアアッッッッププププ方方方方法法法法ののののままままととととめめめめ
この章で説明した新規プロジェクトのセットアップ手順について、簡単にまとめます。
· Project>NewProject で新規のプロジェクトを作成します。
· プロジェクトノードのプロパティーの設定を MPLINK にします。
· ソースファイルを追加して言語ツールの設定を MPLAB-C17 または MPASM にします。
· コンパイル済みのノードを追加します。（.O ファイルおよび.LIB ファイル)
· リンカスクリプトノードを追加します。



Hi-Tech PIC C によるプロジェクトの作成

MPLAB プロジェクトチュートリアル Page 27 改訂B

Hi-Tech PIHi-Tech PIHi-Tech PIHi-Tech PIC C C C CCCC にににによよよよるるるるププププロロロロジジジジェェェェククククトトトトのののの作作作作成成成成
この章では、MPLAB のプロジェクトで Hi-Tech’s PIC C コンパイラを使用してアプリケーション
を構築する方法を示します。前章から続けている場合は、Project>Close Project を選択します。

開開開開発発発発モモモモーーーードドドドのののの設設設設定定定定
Options>Development Mode の設定を MPLAB-SIM シミュレータにして、品名を選択します。この
例では 16C77 PICmicro を選択しています。

図 43
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PIC PIC PIC PIC CCCC 言言言言語語語語ツツツツーーーールルルルののののイイイインンンンスススストトトトーーーールルルル
次の様に PIC C を MPLAB にインストールします。Project>Install Language Tool ダイアログで
HI-TECH ツールを次の例のように設定する必要があります。（パスは異なる場合があります。）

図 44

図 45

図 46

Browse ボタンを使用して、コンパイラ、リンカ、アセンブラとして PICC.EXE を 指定します。
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新新新新規規規規ののののププププロロロロジジジジェェェェククククトトトト
Project>New Project を選択して、新規プロジェクト用のディレクトリを選択後、名前を入力し
ます。¥HT-PIC¥SAMPLES ディレクトリ内で、SAMPLE.PJT と名付けます。

図 47

プロジェクト名の設定後、OK をクリックすると、Edit Project ダイアログが次のように表示さ
れます。

図 48

Language Tool Suite の設定を HI-TECH にします。
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ププププロロロロジジジジェェェェククククトトトトオオオオププププシシシショョョョンンンンのののの設設設設定定定定
Edit Project ダイアログボックスの「Project Files」ダイアログでプロジェクトの名前を選択
して、「Node Properties」をクリックします。次に、言語ツールを「PIC-C Linker」に設定し
て、「Generate  Debug Info」のチェックボックスをオンにします。最後に、次の例のように、
Data 列に「Microchip」と入力します。

図 49

  

注注注注意意意意: : : :  Node Properties ダイアログはツール（この場合 PIC-C）のコマンドラインスイッチを示
します。このダイアログボックスを開くのが 1回目の場合、チェックボックスにはツールに対す
るデフォルト値が表示されます。このチュートリアルで変更が必要なのは、デバッグ情報のセッ
ティングだけです。このコマンドラインスイッチについての詳細は、Hi-Tech のドキュメントを
参照してください。

Node Properties ダイアログで「OK」をクリックして、Edit Project ダイアログに戻ります。

1111 つつつつめめめめののののソソソソーーーーススススフフフファァァァイイイイルルルルのののの追追追追加加加加
Edit Project ダイアログから「Add Node」を選択します。¥HT-PIC¥SAMPLES ディレクトリにある
SAMPLE.C というソースファイルを追加します。

Add Node ダイアログでファイル名が表示されたら、そのファイル名を選択し、「Node
Properties」をクリックします。
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このダイアログは以下のように設定します。
· 「Language Tool」の設定を PIC-C コンパイラにします。
· 「Generate Debug Info」のチェックボックスをオンにします。
· 「Generate Debug Info」の Data 列に「Microchip」と入力します。

図 50

「Object filename」は自動的に「SAMPLE.OBJ」と設定されます。

注注注注意意意意: : : :     Node Properties ダイアログはツール（この場合は PIC C）のコマンドラインスイッチを
示します。チェックボックスにはツールのデフォルト値が表示されます。ここで変更の必要があ
るのは、デバッグ情報だけです。コマンドラインスイッチについての詳細は、Hi-Tech PIC C の
ドキュメントを参照してください。
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OK をクリックして、SAMPLE.C ノードを選択します。次に、「Copy Node」ボタンを使用して、
SAMPLE.C と同じ Node Properties に ADC.C、DELAY.C、LCD.C を追加します。その後、プロジェ
クトの表示は次のようになります。

図 51

ププププロロロロジジジジェェェェククククトトトトのののの作作作作成成成成
メニューから Project>Make Project を選択し、Hi-Tech コンパイラとリンカを使用してアプリ
ケーションをコンパイルします。各ツールを実行する際のコマンドラインを示す Build Results
ウィンドウが作成されます。このウィンドウは次のように表示されます。

図 52
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トトトトララララブブブブルルルルシシシシュュュューーーーテテテティィィィンンンンググググ
問題がある場合は、以下の項目をチェックします。
Project>Install Language Tool... を選択して、PIC C コンパイラと PIC C リンカがどちらも
PICC.EXE になっていることを確認します。

ププププロロロロジジジジェェェェククククトトトトウウウウィィィィンンンンドドドドウウウウ
Window>Project ウィンドウを開くと、次のように表示されます。

図 53
PIC PIC PIC PIC CCCC ププププロロロロジジジジェェェェククククトトトトセセセセッッッットトトトアアアアッッッッププププののののままままととととめめめめ
この章で説明した新規プロジェクトのセットアップ手順について簡単にまとめます。
· PIC C コンパイラ、リンカ、アセンブラの言語ツールをセットアップします。
· 「Include File Directory」を¥HT-PIC¥H (または PIC C の Include ファイルがインストー
ルされている場所)にセットする必要がある場合があります。

· Project>NewProject で新規プロジェクトを作成します。
· プロジェクトノードの「Generate Debug Info」をオンにします。
· プロジェクトノードのプロパティーの設定を PIC C リンカにします。
· ソースファイルを追加し、言語ツールの設定を PIC C コンパイラまたはアセンブラにします。
· 各ソースノードの「Generate Debug Info」をオンにします。
· 各ソースノードの「Generate Debug Info」の Data 列を「Microchip」と設定します。


