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本書は MPLAB 開発システムのインストール、使用方法を段階的に示すチュートリアルです。フロッピ
ーディスク、CD-ROM またはハードディスクのいずれかに MPLAB のインストールファイルを入れてく
ださい。インストールファイルは www.microchip.comからダウンロードできます。

このチュートリアルではテキストに 2 種類のフォントサイズを使用しています。この文章は通常のフォ
ントサイズです。さらに「注意」として、以下のような小さいフォントで補足的な情報を示します。

注意: この文章は注意です。注意はこのチュートリアルに必要不可欠な情報ではありませんが、詳
しい説明を加えるものです。

MPLAB チチチチューューューュートトトトリリリリアアアアルルルル
MPLABは、Microchipの PICmicroコントローラ上で動作するコードの書き込みや、テストを可能にする
統合開発環境です。MPLAB はテキストエディタ、プロジェクト管理機能、組み込みシミュレータなどの
ほか、アプリケーションのデバッグおよびテストを行う各種ツールを備えています。また、Microchip の
言語系製品、デバイスプログラマやエミュレータシステム、サードパーティツールなどの単独ユーザー
インターフェースとなります。

このチュートリアルでは、MPLAB のユーザーインターフェースを簡単に紹介しています。1～2 時間で
10ステップからなるチュートリアルをすべて終了できるでしょう。

MPLABはWindows 3.11用に設計され、Windows 95およびWindows 98で動作します。Windowsやそ
の操作については、理解されていることとして詳しく説明していません。

このチュートリアルで説明するとおりに MPLABを操作すると、以下の事項ができるようになります。
§ MPLABデスクトップを理解する
§ アセンブリソースコードファイルを新規作成し、16F84 の新規プロジェクトを作成する
§ 単純なエラーを発見し、修正する
§ 組み込みシミュレータを稼働させる
§ ブレイクポイントを設定する
§ ウォッチウィンドウを作成する
§ 各種デバッグウィンドウを理解する

本書は MPLAB のすべてにわたって詳細に説明をするものではありません。MPLAB をすぐに使用できる
ように初歩的な説明を行うものです。基本事項を理解してしまえば、Microchip のホームページ
（www.microchip.com.）から、より高度なトピックのアプリケーションやチュートリアルをダウンロー
ドして使用できるようになります。
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ステッステッステッステッププププ 1: インスインスインスインストトトトーーーールルルル
インストール用のソフトウェアファイルをダウンロードし、MPxxxxx.EXE ファイルを実行します。もう
1 台のコンピュータにインストールする場合は、これら別個のファイルをフロッピーディスクへコピー
できます。バージョンによっては、ファイル名が多少異なります。例えば、MPLAB の Version 4.00 は
以下の様なファイル構成となります。

   MP40000.EXE
   MP40000.W02
   MP40000.W03
   MP40000.W04
   MP40000.W05
   MP40000.W06

.EXE ファイルを実行すると、システム上へ MPLAB のインストールが開始します。システムにインスト
ールする MPLAB のファイルを選択することができます。デバイスプログラマやエミュレータをお持ち
でない場合は、以下のソフトウェアツールのみをインストールするのみで構いません。

MPLAB IDE files
MPASM/MPLINK/MPLIB files
MPLAB-SIM Simulator Support Files
Help Files

注意: PICSTART Plus プログラマをお持ちの場合は、 ｢PICSTART Plus Support Files｣も選択して
ください。PICMASTER, MPLAB-ICE, ICEPIC, SIMICEなどのツールがある場合は、ダイアログの
関連項目のチェックボックスをクリックし、そのソフトウェアドライバをインストールしてくださ
い。MPLABをあとで再インストールして、コンポーネントを追加することもできます。
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次のメニューでは、インストールする Microchipの言語コンポーネントを選択できます。通常は、すべて
選択します（デフォルト）。

インストールが終了したら、MPLAB.EXE を実行するか MPLAB のアイコンをクリックし、システムを
起動します。以下のような MPLABのデスクトップが表示されます。
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ステッステッステッステッププププ 2: 開発モ開発モ開発モ開発モーーーードドドドの設の設の設の設定定定定
基本的な MPLAB のデスクトップは、（前ページの図のように）ほとんどの Windows のアプリケーショ
ンと同じです。一番上の行にはメニュー、ツールバー、一番下にはステータスバーがあります。ステー
タスバーには、現在のシステムの設定が出ています。これらの機能については、あとでより詳細に説明
します。ここでは開発モードの設定方法を見てみましょう。

注意: 「Development Mode」ではコードを実行するツールを設定します。このチュートリアルで
は、ソフトウェアシミュレータ MPLAB-SIMを使用します。エミュレータがすでにある場合は、あ
とでエミュレータオペレーションの 1つに切り替えることができます。操作はほとんど同じです。
「Editor Only」モードではコードを実行することができません。「Editor Only」モードはおもに、
シミュレータをインストールしていないか、エミュレータがない場合、または PICmicro のプログ
ラミング用コードを作成するのみの場合に使用します。

「Options>Development Mode」のメニュー項目を選択すると、下の図のようなダイアログボックスが開
きます。

MPLAB は常にバージョンアップが行われている製品なので、画面に表示されるダイアログボックスは、
ここに示したものと若干違っているかもしれません。 MPLAB-SIM シミュレータのラジオボタンをクリ
ックし、プルダウンメニューにある、シミュレータがサポートしているプロセッサの中から 16F84 を選
択します。16F84をクリックしたあと、「Reset」ボタンをクリックします。シミュレータは初期化され、
「16F84」と「Sim」が MPLABのデスクトップの下にあるステータスバーに表示されます。これで、16F84
のシミュレータモードに設定されました。
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ステッステッステッステッププププ    3: 簡単な簡単な簡単な簡単な新新新新規プロジェ規プロジェ規プロジェ規プロジェククククトの作トの作トの作トの作成成成成
このシミュレータは、PICmicroへプログラム書き込みするための「hex file」と呼ばれるファイルを使用
して動作します。シミュレータを動作させるには、まずソースコードファイルを作成し、そのソースコ
ードを正しくアセンブルします。

注意: アセンブラは、hex fileを生成します(他のものも生成しますが)。このファイルにはファイ
ル拡張子.hexが付いています。このチュートリアルでは、このファイル名は tutor84.hexとします。
あとでこのファイルは、アセンブラーまたは MPLABプロジェクトを使用しないで、直接デバイス
プログラマへロードすることができます。またこのファイルは、ほとんどのサードパーティのプロ
グラマにもロードできます。

メニューの「File>New」を選択すると、以下のようなダイアログが表示されます。

「Yes」をクリックすると、Windows の通常のブラウズダイアログが出ます。プロジェクトを作成する
ディレクトリを決めて、あとで必要になる場合に備えて、その場所を覚えておきます。このチュートリ
アルでは c:¥temp¥tutorial のディレクトリを使用し、プロジェクトファイル名を tutor84.pjt と
します。

「PJT」は、MPLABのプロジェクトファイルに通常使用される拡張子です。プロジェクトファイル名(こ
のチュートリアルでは「tutor84」)は、MPLAB が使用したり、作成したりするファイルのほとんどでデ
フォルト名として使用されます。
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マウスを使用して「OK」をクリックすると、MPLAB プロジェクトダイアログが開きます。このダイア
ログは複雑に見えますが、実は非常に単純です。

注意: MPLABで使用するシミュレータ、プログラマおよびエミュレータシステムは、ソースコー
ドをアセンブルしたり、コンパイルまたはリンクして作成された hex fileを使用します。いくつか
の異なるツールによっても hex fileは作成でき、それらのツールはそれぞれのプロジェクトの一部
分となります。プロジェクトを作成することで、どのようにアプリケーションが構築されているか
や、どのソフトウエアツールが.hex fileの作成に使用されているかをを柔軟に設定できます。この
チュートリアルでは、これらの事項については詳しく説明しませんが、必要に応じて、「Node
Properties」を使用して設定を行ってください。より複雑なプロジェクトについては、MPLAB v3.40
Project Tutorialを参照してください。

「Edit Project」のダイアログは、以下のように表示されます。

Target Filename に指定したファイル名があるか確認してください。前もって設定した開発モードはすで
に認識されています。デフォルトで Microchip の言語ツールを使用する設定となっています。「Project
Files」のウィンドウには tutor84.[hex] と表示されます。このファイル名をハイライトすると、「Node
Properties」のボタンが有効になります。最初に、MPLAB に hex file の作成方法を指定しなければなり
ません。これを行うには、「Node Properties」のボタンをクリックします。「Node Properties」のダイ
アログが開きます。
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このダイアログには、言語ツールのデフォルト設定がすべて表示されます。この場合は、ダイアログの
右上にあるように MPASM となっています。最も簡単なプロジェクトは、1 つのアセンブリソースファ
イルで hex file を作成するプロジェクトです。下の図は、「Node Properties」のダイアログが表示され
た時のデフォルト設定です。

注意: このダイアログには、多くの行と列があります。列はそれぞれ「スイッチ」と対応しており、
ツールが起動された時にコマンドラインに設定される項目です。実際、これらのスイッチの設定は、
下の方にある「Command Line」のウィンドウに表示されます。これは、MPLABから MPASMを
起動する時に発行される実際のコマンドラインです。ここでは、デフォルト設定を使用しますが、
アプリケーションの構築に慣れてくると、変更したい設定がでてくるかもしれません。

「OK」をクリックすると、デフォルト設定され、「Edit Project」のダイアログへ戻ります。「Add Node」
のボタンが有効になります。

「Add Node」のボタンをクリックすると、ウィンドウの通常のブラウズダイアログが開きます。プロジ
ェクトのディレクトリと同じディレクトリが表示されます。ファイル名 tutor84.asm を入力し、「OK」
をクリックします。「Edit Project」のダイアログに戻り、「tutor84.asm 」が使用されているノードと
して hex fileの下にインデントされます。

「OK」をクリックすると、MPLAB のデスクトップへ戻り、オープンされているが、まだファイル名が
付いていないソースコードファイルが表示されます。
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ステッステッステッステッププププ 4: 簡単な簡単な簡単な簡単な新新新新規ソースフ規ソースフ規ソースフ規ソースファァァァイルの作イルの作イルの作イルの作成成成成
作成された空のファイルウィンドウのブランクスペースを、一回クリックします。題名は「Untitled」と
なっていますが、これによって、この空のウィンドウはフォーカスされます。「File>Save As…」のメ
ニューオプションを使用し、この空のファイルを tutor84.asm という名前で保存します。通常のブラ
ウズダイアログが開くと、プロジェクトの現在使用中のディレクトリになっています。ファイル名を入
力して「OK」をクリックします。

これで MPLAB デスクトップと空のファイルウィンドウが表示されます。ファイルウィンドウ名は更新
されています。

注意: この種のプロジェクトでは、ソースファイル名とプロジェクト名は同じでなければなりませ
ん（このチュートリアルでは「tutor84」)。リンカを使用した複数ファイルのプロジェクトは入力
ファイル名と違うファイル名を出力ファイル名にすることができます（リンカを使用するマルチフ
ァイルプロジェクトには別のチュートリアルがあります）。このチュートリアルでは、１つのソー
スファイルのプロジェクトなので、MPASMは常に出力 hex fileをソースファイルと同じファイル
名で作成するので、これを変更できません。ソースファイル名を変更する場合は、必ずプロジェク
ト名も変更してください。
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ステッステッステッステッププププ 5: ソースソースソースソースココココードの入ードの入ードの入ードの入力力力力
マウスを使用してカーソルの位置を tutor84.asm の空のファイルウィンドウの中に置きます。以下の
テキストを示したとおりに入力します。セミコロンの後に続くコメント文は入力する必要はありません。

    list    p=16f84
    include <p16F84.inc>

c1  equ     h’0c’ ; Set temp variable counter c1 at address 0x0c

    org     h’00’  ; Set program memory base at reset vector 0x00
reset
    goto    start ; Go to start of the main program

    org     h’04’ ; Set program memory base to beginning of user code
start
    movlw   h’09’  ; Initialize counter to arbitrary value greater than zero
    movwf   c1    ; Store value in temp variable a defined above
loop
    incfsz  c1,F  ; Increment counter, place results in file register
    goto    loop  ; Loop until counter overflows

    goto    bug ; When counter overflows, got to start to re-initialize
    end

このコードは大変簡単なプログラムで、カウンタをインクリメントし、カウンターがゼロになったらあ
らかじめ決めた値にリセットします。

注意: すべてのラベルは最初の列から記入します。最後の行には「end」疑似命令を付けます。疑
似命令についての詳細は、MPASMと MPLINKおよび MPLIBユーザーガイドを参照してください。
PICmicroのデータシートには使用例と命令についての説明が記載されています。

「File>Save」 メニューの機能を使用してファイルを保存します。
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ステッステッステッステッププププ 6: ソースソースソースソースフフフファイルのアァイルのアァイルのアァイルのアセセセセンブンブンブンブルルルル
ファイルをアセンブルする方法はいくつかあります。ここに示した方法はその一つです。「Project>Build
All」 メニュー項目を使用します。これは、前述のプロジェクトで保存したデフォルトを使用して、バッ
クグラウンドで MPASM アセンブラを実行します。アセンブル処理が完了すると、「Build Results」ウ
ィンドウが表示されます。

前出の通りにコードを入力した場合、少なくとも 1 つのエラーを意図的に入力しました。プログラムの
最後の「goto」  は「bug」という名の存在しないラベルを参照しています。このラベルはあらかじめ定
義されていないので、アセンブラはエラーを報告します。他にもエラーがある場合があります。

マウスを使用してエラーメッセージをダブルクリックします。 こうするとカーソルがソースコードの中
のエラーのある行に移動します。「bug」を「start」に変更します。「Build Results」ウィンドウを使用
してエラーを検索して、ソースコードの中の他のバグを修正することができます。「Project>Build All」
メニュー機能を実行して再アセンブルします。エラーがなくなるまでこの手順を何度か繰り返します。

注意:  プロジェクトを再構築する時に、すべてのソースファイルがディスクに保存されます。

ソースコード中のすべての問題を修正すると、「Build Results」ウィンドウに「Build completed
successfully.」と表示されます。これで、シミュレーターを使用して実行できるプロジェクトができまし
た。
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ステッステッステッステッププププ 7: プログプログプログプログララララムの実ムの実ムの実ムの実行行行行
 「Debug>Run>Reset」を使用してシステムを初期化します。プログラムカウンターはゼロにリセット
されます。これは 16F84 のリセットベクタです。このアドレスのソースコードの行はダークバーでハイ
ライトされます。MPLABの一番下のステータスバーで、PCが 0x00にセットされます。

 「Debug>Run>Step」のメニュー項目を使用すると、次の命令の位置へプログラムカウンタが進みます。
このダークバーはソースコードに続き、ステータスバーに表示されたプログラムカウンタは「４」へと
進みます。

「Debug>Run>Step」のメニュー項目を実行すると「F7」というメニュー項目が右側に表示されます。
これはキーボード上の 「ファンクションキー 7」 を表します。多くの MPLAB機能は｢ホット・キー｣に
割り当てられています。これらのキーはメニュー項目そのものを実行するのと同じことができます。F7
を数回押し、プログラムを通してプログラムカウンタとダークバーがプログラムにより進むのを確認し
てください。

「Debug>Run>Run」メニュー項目を実行するか F9 を押して、現在のプログラムカウンターの位置から
プログラムを実行開始します。ステータスバーは色を変えて、プログラムが命令を実行していることを
示します。ステータスバーの他のフィールドはプログラムが停止するまで更新されません。

「Debug>Run>Halt」メニュー項目を実行するか F5 を押して、プログラムを停止します。ステータスバ
ーが元の色へ戻り、現在のプログラムカウンターと他のステータス情報が更新されます。
  

注意:  画面上部のツールバーを使用して機能を実行する方法もあります。ツールバー上の項目に
カーソルを置くと、下にあるステータスバーの中に機能の名前が表示されます。ツールバーの左端
のボタンは標準の「変更ツールバー」ボタンです。利用できるいくつかのツールバーをスクロール
することができます。これらは、チュートリアルの最後の「ヒントとコツ」で説明しますが、カス
タマイズできます。デバックツールバーでは、緑のライトが F9 (Run) に相当し、赤のライトが F5
(Halt) となります。
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ステッステッステッステッププププ 8: その他その他その他その他ののののデバック用デバック用デバック用デバック用ウウウウィンドウのオープィンドウのオープィンドウのオープィンドウのオープンンンン
MPLAB を使用してプログラムの実行状況を確認する方法はたくさんあります。例えば、このプログラム
はテンポラリーのカウンタをインクリメントしますが、それが確実に実行されているのをどのように確
認できるでしょうか。一つは、ファイルレジスターウィンドウを開き、詳しく調べる方法があります。
「Window>File Registers」メニュー項目を実行してください。すべてのファイルレジスタまたは 16F84
の RAMのウィンドウが表示されます。

F7  (シングルステップを実行) を数回押して、ファイルレジスタウィンドウの値が更新されているのを
確認します。カウンターの変数をアドレスの 0x0C に置きます。テンポラリーのカウンタがインクリメ
ントしたら、ファイルレジスタウィンドウに反映されます。簡単に確認できるように値が変化した時に
色が変わるようになっています。しかし、非常に複雑なプログラムの場合、多くの値が変わることがあ
るので、1 または 2 つの変数に注目することが困難になります。この問題は、ウォッチウィンドウを使
用することで解決します。
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ステッステッステッステッププププ 9: ウォッウォッウォッウォッチチチチウィンドウウィンドウウィンドウウィンドウのののの作作作作成成成成
「Window>New Watch Window」メニュー項目を実行します。「Add Watch Symbol」ダイアログが表示
されます。

シンボル名のボックスに 「c1」 と入力すると、希望の記号にスクロールできるリストが表れます。希
望の記号をハイライトして「Add」ボタンをクリックし、次に「Close」ボタンをクリックします。MPLAB
デスクトップ上のウォッチウィンドウにテンポラリーのカウンタ値「c1」 の現在の値が表示されます。

F7 を押してプログラムを数回シングルステップすると、カウンタをインクリメントするごとにウォッチ
ウィンドウのディスプレイが更新されます。ファイルレジスタウィンドウをオープンのままにした場合、
同様に更新されます。

オプション ウォッチウィンドウの保存
 ウォッチウィンドウのシステムボタンの下にある 「Save Watch」 項目を実行すると、ウォッチウィ
ンドウとそのセッティングの保存ができます。システムボタンはウォッチウィンドウの左上の角にあり
ます。このボタンをクリックすると、メニューが下へカスケード表示されます。「Save Watch」を選択
すると、標準ブラウズダイアログを使用してプロジェクトの現在作業中のディレクトリが表示されます。
任意の名前を入力して「OK」を押してください。

ウォッチウィンドウに名前を付けない場合、MPLABが名前を付けます。次にプロジェクトを開いた時に、
ウォッチウィンドウも修復されるように、ウィンドウのオープンまたはクローズ状態とスクリーン上の
位置がプロジェクトとともに保存されます。

注意:  ウォッチウィンドウは、作成後にもエディットできます。システムボタンを使用して 「Add
Watch」を選択し、ダイアログを立ち上げて項目を追加します。「Ins」キーでも同じことができ
ます。項目をハイライトし、Deleteキーを押すとウィンドウからその項目が消去されます。シス
テムメニューから「Edit Watch」を選択し、項目の表示方法（16進、バイナリ、8ビットではな
く 16ビットの変数としてなど）を変更することもできます。
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ステッステッステッステッププププ 10: ブレーブレーブレーブレーククククポイントのポイントのポイントのポイントの設設設設定定定定
F5 (｢Debug>Run>Halt｣)を押してシミュレータのプロセッサが停止しているのを確認します。「movlw
h’09’」と書かれた「Start」ラベルの直後の行にあるソースコードウィンドウをクリックします。  マウ
スの右ボタンを押すとメニューが表示されます。

「Break Point(s)」メニュー項目をクリックすると、メニューが消えてカーソルが置かれていた行の色が
変わり、ブレイクポイントがその位置に設定されていたことを示します。

F6 を押して「Debug>Run>Reset」メニュー項目を実行し、システムをリセットします。次に、F9 を押
してシステムを実行開始します。プログラムが実行開始され、ブレークポイントの直後で命令が停止し
ます。「c1」は、ウォッチウィンドウやファイルレジスタウィンドウに表示されますが、MPLAB 起動後
のリセットステータスのゼロとなります。１ステップ進むとロードを実行し、c1は 0x09になります。F9
を数回押すと実行中にステータスバーの色が変わり、プロセッサが停止すると再び色が変わります。

まとまとまとまとめめめめ
このチュートリアルでは以下の方法を説明しました。
· 新規プロジェクトの設定
· ソースファイルの作成とプロジェクトへの入力
· コードのアセンブル
· シミュレータを使用したコードの実行
· ブレイクポイントの設定とコードのシングルステップ
· コードの変数の確認

ここで紹介したトピックを慣れましたら、次章でさらに MPLAB の他の機能についての説明をご覧くだ
さい。
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ヒントとコヒントとコヒントとコヒントとコツツツツ
ブブブブレレレレーーーーククククポポポポイイイインンンントトトト  –「Windows>Program Memory」ウィンドウ、ソースファイルウィンドウ(今回は
tutor84.asm)、または「Windows>Absolute Listing」ウィンドウでブレイクポイントを設定します。

ソソソソーーーーススススフフフファァァァイイイイルルルル - 「Window>Project Window」を使用してソースファイルのリストを表示します。ファ
イル名をダブルクリックし、エディタにファイルを表示します。

MPASM エエエエララララーーーー - MPASM にエラーが発生した場合、エラーウィンドウの中のエラーをダブルクリック
して、ソースコードのエラーへ進みます。複数のエラーが発生した時は常に最初のエラーを選択してく
ださい。（１つのエラーが次のエラーの原因となることが多いので、最初のエラーを修正するとすべて
が修正されることがあります。）

ココココンフンフンフンフィグィグィグィグレレレレーシーシーシーションョンョンョンビッビッビッビットトトトおよおよおよおよびプびプびプびプロロロロセセセセッッッッサモサモサモサモードードードード－－－－ソースファイルの中のコンフィグレーションビ
ットはシミュレータ（またはエミュレータ）のプロセッサーモードを設定しません。「Options>Processor
Setup>Hardware」を使用して設定します。MPASM または MPLAB-C17 ソースファイルにこれらのビッ
トを設定できますが、MPLAB は自動的にモードを変更しません。例えば、デバイスにプログラムを書き
込む時、Watch Dog Timer Enableコンフィグレーションビットは設定可能なので、Watch Dog Timer が
オンになるように設定できます。MPLAB では、シミュレータまたはエミュレータで WDT をイネーブル
するには、更に「Options>Processor Setup>Hardware」ダイアログで設定する必要があります。これに
よりソースコードを変えずにWDTをオンまたはオフにしてデバックすることができます。

オオオオププププシシシショョョョンンンン - 次の事柄を行うには「Options>Environment Setup」へ進みます。
· MPLAB機能と特別な ASCII文字を Europeanキーにマッピングする。
· スクリーンフォント、またはフォントサイズを変更する。
· ツールバーを画面の横、または下に配置する。
· ツールバーを変更する。
· 表示するラベルの文字数を変更する。

ママママッッッッププププフフフファァァァイイイイルルルル - 「Project>Edit Project」ダイアログへ進み、MPASM のノードプロパティを変更して
tutor84.map. という MAPファイルを作成します。プロジェクトを構築したら tutor84.map を見て、
ビルド情報を確認してください。

ググググレレレレイイイイアアアアウウウウトさトさトさトされれれれたたたたメメメメニニニニュュュューーーー – メニューの表示がグレイアウトされている場合は、「Editor Only」モー
ドになっていないことを確認してください。すべてが正しく設定されているなら、MPLAB を再起動して
ください。
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チュートリアチュートリアチュートリアチュートリアルルルルでででで説説説説明明明明ししししてててていいいいなななないいいい    MPMPMPMPLLLLAAAAB B B B 機機機機能能能能
MPLAB にはこの簡単なチュートリアルで説明している以外にも多くの機能があります。すべての機能
について踏み込んだ説明をして、極端に長く複雑なチュートリアルにしてしまうより、ここでは MPLAB
についての基本的な知識を身に付けましょう。MPLAB の基本的なもの以外のツールについてもいくつ
か説明しています。

他のデ他のデ他のデ他のデーーーータウィンドタウィンドタウィンドタウィンドウウウウおよびダイアロおよびダイアロおよびダイアロおよびダイアロググググ
チュートリアルではプログラムメモリウィンドウとウォッチウィンドウについて説明しました。その他
のウィンドウについては説明しませんでした。「Window>Stack」および「Window>Special Function
Registers」を選択すれば、MPLAB は他のメモリ領域も表示できます。。

ブレークポイント設定のための「Debug>Break Settings…」ダイアログなど、他のダイアログもありま
す。

これらの機能に関してはオンラインヘルプおよび MPLAB ユーザーズガイドで説明しています。

トレートレートレートレースススス
トレースウィンドウではプログラム実行の「スナップショット」を撮ります。トレースバッファを備え
たエミュレータでは、作成したプログラムが実際の速度でどのように実行しているかを表示できます。

注意: モーターの制御システムなど、停止させることができないアプリケーションもあります。バグの
中にはアプリケーションが稼働している間だけ現われるものもあります。(シングルステップでコード
を実行してもバグが発生しない場合) トレースバッファなら別のツールでそのようなアプリケーション
をテストできます。ハードウェアのトレースバッファに収集した情報に関しては、エミュレータのユー
ザーズガイドで確認してください。

シミュレータでは、トレースバッファは長いプログラム実行記録の収集をするのに役立ちます。記録の
収集により、あとで、戻って解析をすることができます。その場合、シミュレータはエミュレータのト
レースとは多少異なる情報を提示します。

シミュレータのトレースバッファを使用するには、まずトレースするコードを選択する必要があります。
トレースする命令を選ぶプログラム・メモリ・ウィンドウ全体をクリック･アンド･ドラッグする場合は、
マウスの右ボタンをクリックします。するとダイアログが表示され、「Trace Point(s)」を選択すること
ができます。

プログラムをリセットし、実行します。数秒実行した後、停止させます。「Window>Trace」を選択し、
収集されたトレースを確認します。

シミュレータは各行に時刻を書き込み、変更したレジスタとその値を表示します。.
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スティスティスティスティミミミミュラュラュラュラスススス
スティミュラスはシミュレータへの入力信号を生成します。ピンを High または Low に設定したり、値
を直接レジスタに入力することができます。スティミュラスには以下の 4 モードがあります。
· 非同期スティミュラス – 入力ピンの信号をダイアログのボタンを使用して制御します。
· スティミュラス・ピン・ファイル – テキストファイルの内容をピンの入力信号として入力します。
· スティミュラス・レジスタ・ファイル – テキストファイルの内容を使用して、レジスタに直接 8 ビ

ットの値を入力します。
· クロックスティミュラス – プログラム可能なクロックを入力します。

非同期スティミュラスダイアログ
このスティミュラス機能では、入力ピンに印加されている High レベルと Low レベルをダイアログのボ
タンを使用して入力します。シミュレータでプログラム実行中に、このダイアログのボタンを押して、
ピンのレベルを変更できます。

例として、16F84 の PORTBの I/Oピンのレベルをトグルさせるように設定します。

「Debug>Simulator Stimulus>Asynchronous Stimulus…」を選択します。

次のダイアログが表示されます。

「Stim1(P)」ボタン上にカーソルを置き、マウスの右ボタンをクリックします。ダイアログが表示され
ます。スクロールダウンして、「Toggle」をクリックします。
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再びカーソルを「Stim1(T)」（P が「Toggle」を意味する T になっている）ボタンの上に置き、マウス
の右ボタンをクリックし、「Assign Pin…」を選択します。

16F84 のピンのリストのダイアログが表示されます。

カーソルを「RB0」に合わせて、ダブルクリックします。

非同期スティミュラスダイアログが以下のように表示されます。

ボタンは「RB0(T)」になっていることを確認してください。

「Debug>Run>Animate」を選択して、「連続シングルステップ」モードでプロセッサを走らせます。実
行を停止する場合はステータスバーを使用すると迅速に行えます。

非同期スティミュラスダイアログの「RB0(T)」ボタンを押します。「RB0(T)」ボタンを繰り返しクリッ
クするごとに PORTB の 0番ピンへの入力信号がハイ、ロー交互に変化しているのが「Special Function
Register」ウィンドウの PORTB の値が変化することで確認できます。
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ピンスティミュラスファイル

ピンスティミュラスファイルは CYCLE とピン入力レベル(1 または 0)の列から構成され、CYCLE 列が
ストップウォッチの「Cycle」の値と一致した時に 1または 0がピンに入力されます。

「File>New File 」を選び、以下のテキストを入力します。「;」や「!」のコメントの区切り文字以降は
入力する必要はありません。

CYCLE   RB1    RB0
20      0       0
41      1       0   ; apply high to port b bit 1
52      0       1   ; apply high to port b bit 0, set bit 1 low
55      1       1
60      0       0
65      1       0   ; toggle bit 1, then...
76      0       1   ! ...toggle bit 0.

「File>Save As…」を選択して tutor84.sti  という名で保存します。

注意: 以前のバージョンの MPSIM と互換性をとるために、一行目は必ず「CYCLE」または「STEP」
というワードで始めます。この CYCLE列で同じ行の他の列の値が入力される CYCLE (MPLAB の
ストップウォッチウィンドウ) を指定します。

ファイルの 1行目の「CYCLE」というワードの後には、Highおよび Lowを疑似入力される PICmicro の
ピン名を記述します。この例では、PORTBの 2 つのピンである RB1 と RB0 に疑似入力されます。

このファイルでは、RB1 (PORTB ビット 1) に適用する値は第 2 列に、RB0 (PORTB ビット 0)の値は
第 3 列にあります。これらの名前は、シミュレーションする PICmicro のピン名と一致していなければ
なりません。

注意: 非同期スティミュラスのピン割当てプルダウンに、サポートしているすべてのピンのリスト
があります。(疑似入力ボタンを右クリックしてください。)
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「;」または「!」文字の後 1 スペース以上空ければ行にコメントを記述することができます。
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それぞれの命令が実行された時の経過時間が、CYCLE 値とクロック周波数により計算され、ストップウ
ォッチウィンドウに表示されます。ストップウォッチを 0 にリセットすれば、ピンスティミュラスファイ
ルもリセットされたことになります。

「Window>Stopwatch」を選択してストップウォッチウィンドウを開きます。さらに「Window>Special
Function Registers」を選択します。その中で「portb」を重点的に見たい時、ウォッチウィンドウに portb
を追加することもできます。

リセットして、41 サイクルになるまでシングルステップを実行します。これで、スティミュラスファイ
ルの二行目に記述したように、「portb」の値が変化します。
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レジスタ･スティミュラス･ファイル

レジスタのスティミュラスファイルは、プログラムメモリのアドレスがレジスタ・スティミュラス・ダ
イアログで設定したロケーションを実行したときにレジスタに入力される 1 列からなる値で構成されま
す。これは A/D 変換のシミュレーションに役立ちます。

「File>New File」を選択して新しいファイルを開き、次の数字のリストを入力します。

10
2E
38
41
50
7A
99
A0
FD

「File>Save As…」を選択し tutor84.reg  という名で保存します。

これらの値は順番にレジスタに入力されます。「Simulator Stimulus> Register Stimulus>Enable…」を選
択します。
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デモンストレーションのために、値が入力されるプログラムの場所を「loop」に設定して、デモンスト
レーションのために、アドレス 0x0d のファイルレジスタに値を入力してみましょう。該当する欄に「ル
ープ」と「0d」を設定したら、「Browse」を押してファイルダイアログを表示します。次にレジスタの
スティミュラスファイルである tutor84.reg を選択します。

「Window>File Registers」でウィンドウを開き、値が入力されたことを確認します。

リセットした後、プロセッサをシングルステップします。「loop」を実行するたびに 0x0D のファイル
レジスタの値が変わります。tutor84.reg  の中の値が選択したファイルレジスタ (上記で 0x50 の値
となっている 0x0D) に順番に入力されるはずです。0x10、0x2E などの値が「loop」を実行するたびに
「Debug>Simulator Stimulus>Register Stimulus」ダイアログで選択したレジスタに入力されます。

最後の値  (tutor84.reg 内の  0xFD) が入力された後は、再び最初の値  (0x10) が使用されます。
MPLAB-SIM を実行中、リストは循環します。
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クロックスティミュラス
クロックスティミュラスは、プロセッサのクロックサイクルで指定したデューティサイクルでピン上に
規則的な波形を入力します。

上図の「Debug>Simulator Stimulus>Clock Stimulus…」ダイアログで、いろいろな疑似入力クロックを
入力することができます。上記の設定でプログラムをシングルステップまたは実行した場合、RB3 は 4
クロックサイクル High になり、その後 6 クロックサイクル Low になります。RB4 は 8 クロックサイ
クル High になり、その後 8 クロックサイクル Low になります。MPLAB を終了したり、このダイアロ
グで設定を削除するまで、この入力は繰り返されます。
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条件付条件付条件付条件付ききききブレーブレーブレーブレークククク(Conditional Break)
この複雑なブレークポイントのダイアログは特別な複雑な状態のブレークポイントの設定に役立ちます。
MPLAB ユーザーズガイドを参照してください。

エディエディエディエディタタタタ機機機機能能能能
MPLAB のエディタにはソースコードの記述、編集に便利な機能がたくさんあります。詳細は MPLAB ユ
ーザーズガイドを参照してください。

ストッストッストッストッププププウォッウォッウォッウォッチチチチ
ストップウォッチによりコードの実行時間を測定できます。シングルステップでは正確に測定できませ
ん。ストップウォッチは、PICmicro のクロック周波数をベースにして時間を計算します。
「Options>Processor Setup>Clock Frequency…」ダイアログでクロック周波数を設定します

複数フ複数フ複数フ複数ファァァァイルプロジイルプロジイルプロジイルプロジェェェェクトクトクトクト
リンカを使用すると、複数ファイルのプロジェクトを作成できます。MPLAB v3.40 Project Tutorial を参
照してください。

MPASM
MPLINK、MPLIB および MPASM のユーザーズガイドではアセンブラ、リンカ、ライブラリアンの操
作について詳細が述べられており、マイクロチップのホームページからダウンロードすることができま
す。

PICMASTER, ICEPIC, MPLAB-ICE
エミュレータの操作方法のユーザーズガイドはそれぞれ別冊になっています。マイクロチップのホーム
ページからダウンロードすることができます。

PICSTART Plus, PRO MATE
マイクロチップのデバイスプログラマです。MPLAB PRO MATE ユーザーズガイドおよび PICSTART
Plus ユーザーズガイドを参照してください。どちらのマニュアルもマイクロチップのホームページから
ダウンロードすることができます。

MPLAB-C17
17cxxx コンパイラは MPLINK および MPLAB のプロジェクトマネージャ上で使用できます。MPLAB-
C17 ユーザーズガイド、および MPLAB v3.40 プロジェクトチュートリアルを参照してください。

サードサードサードサードパパパパーティのツーティのツーティのツーティのツーーーールルルル
HiTech社 の PIC C、CCS社のCCS コンパイラ、および Micro Engineering社 の PIC BASIC をMPLAB
上で使用できます。MPLAB 上で使用方法についてはそれぞれの説明書を参照してください。
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問題が問題が問題が問題が発発発発生した場生した場生した場生した場合合合合

www.microchip.com の PICmicro および開発システム会議にアクセスして、初心者から専門家まで対応
しているフォーラムで質問してください。Microchip のアプリケーションエンジニア、PICmicro に精通
したユーザー、および開発システムエンジニアがこの会議に出席していますので、問題解決、問題報告
の最短距離です。また、これまで出た問題を見るだけでも何かの助けになるでしょう。(英語です)

Microchip のホームページでは本、記事、オンライン討論グループなど、その他にも役に立つサイトへの
リンクがあります。

日本語での技術的な質問は代理店またはマイクロチップテクノロジー Int'l Inc.日本支社までお問い合わせ
ください。マイクロチップテクノロジーへの技術的な質問は FAX にて FAX:045-471-6122 までお問い合
わせください。(技術的な質問用の記入用紙も用意していますので、TEL:045-471-6166 までお問い合わ
せください)
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用語用語用語用語集集集集

アセンブラリスト(Absolute Listing) – プロジェクト構築の際に生成されるファイル。これは実際に
生成されたコードとソース命令を表示します。MPASM のマクロを使用する場合、またはコンパイ
ラを使用している場合に役立ちます。特にデバッグ時に有効です。なぜなら、このウィンドウの行
を追ってコンパイラが生成したコードを確認し、高級言語では見つけにくい微妙な干渉などを突き
止めることができるからです。

アセンブラ – アセンブラのニーモニック命令をマイクロコントローラで実行するためにマシンコー
ドに変換するプログラム。ニーモニックとマシンコードは一対一で対応しています。

ブレークポイント – デバッグを支援するためにプログラムに設定する停止ポイント。プログラム実
行中、このプレークポイントで実行を中断し、内部レジスタとユーザー変数の確認ができます。

プロジェクト構築(Build Project) – １つのプロジェクト内のコンポーネントすべてをアセンブル、
またはコンパイルすること。

コンパイラ – 高級言語の文をマイクロコントローラで実行するためにマシンコードに変換するプロ
グラム。高級言語の１つの文からは、通常多数のマシンコード命令が生成されます。

開発モード(Development Mode) – ツールがある場合、どのツールでコードを実行するかを設定し
ます。このチュートリアルではソフトウェアのシミュレータである MPLAB-SIM を使用しました。
MPLAB-ICE のようなエミュレータをインストールしている場合には、エミュレータを使用するモ
ードに切り替えることができます。「Editor Only」モードではコードを実行することはできません。
このモードは主に、PICmicro デバイスにプログラム書き込みのみを行う時に使用します。

デバイスプログラマ– ファイルからマシンコードをリードして、プログラム可能なマイクロコント
ローラまたはプログラム可能なメモリチップへプログラムを書き込むハードウェア機器。

エミュレータ – アプリケーション上で実際のマイクロコントローラの代わりに使用するハードウェ
ア機器。エミュレータにより、アプリケーション開発の最終段階で行うマシンコードのダウンロー
ド、実行、テストが迅速に行えます。

ファイルレジスタ – 変数を記憶するために使用する PICmicro 内の内蔵 RAM の領域。

停止(Halt) – ブレークポイントの結果生じるデバッグ機能。対象となるマイクロコントローラを任
意のプログラムメモリアドレスで停止させ、レジスタや変数を調べます。

HEX ファイル – ASCII 形式のマシンコード。HEX ファイルは、マイクロコントローラの命令また
はデータを指定するレコードから構成され、プログラム可能なメモリデバイスに格納されます。

IDE – Integrated Development Environment(統合開発環境)の略。コード開発のために複数の機能や
特性を使用するアプリケーション。別のプログラムを起動しなくてもいろいろなツールを使用でき
ます。

リンカ – オブジェクトコードを実行可能なマシンコードに変換するためのプログラム。リンカは、
コードをメモリのどこに書き込むか、変数用に RAM をどのように使用するかを決定します。

ノード – Edit Project ダイアログの Project Files ウィンドウの一覧の中にあるファイルの一つ。出
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力であるプロジェクトノードが 1 つと、1 つまたは複数の入力ノードがあります。このチュートリ
アルで使用している入力ノードは 1つの MPASM ソースファイルのみです。プロジェクトタイプに
よっては、複数のアセンブリファイル、C ソースファイル、コンパイル済のオブジェクト、ライブ
ラリ、および、リンカ･スクリプト･ファイルなどたくさんの入力ノードを使用することもあります。

オブジェクトコード – アセンブラまたはコンパイラが生成する中間コード。このコードにはプログ
ラムメモリ、または、内蔵 RAM 変数用のアドレスはありません。しかし、リンカがこのコードを
プログラムメモリに配置する際に決定するアドレスのマーカーを含んでいます。

プログラムメモリ – アプリケーション実行用の命令セットを格納しているマイクロコントローラ内
のメモリ。

プロジェクト –アプリケーションの作成に使用する複数のファイル群。ファイルを実行可能なマシ
ンコードに変換する際に必要なアセンブラ、コンパイラ、リンカの指定も含みます。これらのファ
イルはアセンブラのソースファイル、コンパイラのソースファイル、ライブラリ、コンパイル済の
オブジェクトファイル、およびリンカスクリプトと呼ばれる疑似命令ファイルなどです。

シミュレータ – パソコン上でマイクロコントローラの疑似動作を行うソフトウェアプログラム。

ソースコード – アセンブラまたはコンパイラが処理するテキストファイル。処理後、中間オブジェ
クトファイルやマイクロコントローラで実行するためのマシンコードが生成されます。

特殊機能レジスタ – コントローラ、または、周辺機能の内部動作を制御するためにの PICmicro の
内部レジスタ。割込み制御レジスタ、タイマ、および 、I/O レジスタなどがあります。

トレース – マイクロコントローラの命令の実行を表示するウィンドウ。エミュレータには、ターゲ
ットプロセッサ動作中にリアルタイムに情報を収集するハードウェア･トレース･アナライザがあり
ます。このデータはトレースウィンドウにアップロードされ、MPLAB で見ることができます。ま
た、シミュレータでもトレースは行えます。

ウォッチウィンドウ – 選択した変数の内容を表示します。ASCII、hex 、バイナリ、浮動小数点な
どのフォーマットで値が表示できます。


